Card details are not getting updated. Update Billing Settings is not working fine.
Resolved
This incident has been resolved.
Posted May 09, 2020 - 05:38 CDT
Investigating
We are currently looking into the issue. Update Billing settings option under settings->Subscription Settings->Edit Billing Settings->Enter details->Update Billing settings. After clicking of Update Billing settings, nothing happens. It just spins and stays on the same page. The development team is working on this issue. Hopefully, Update Billing Settings shall be working in a short time. No other components are affected. The issue will be resolved as soon as possible.

ETA:- 2 Days.
Posted May 04, 2020 - 10:51 CDT