The copperegg app.copperegg.com url is down.
Resolved
This incident is resolved. The copperegg url is working fine now.
Posted Dec 12, 2023 - 01:28 CST
Investigating
The app.copperegg.com is down. Our development team is working on it to get it fixed.
Posted Dec 11, 2023 - 16:44 CST
This incident affected: Web Application Interface.